Berlin:Firmware

Aus wiki.freifunk.net
Wechseln zu: Navigation, Suche
  • Firmware

Die Berliner Freifunk-Firmware "kathleen" hatte ihr erstes Release (Version 0.0.0) im Herbst 2014. Wie die meisten anderen Freifunk-Firmwares baut sie auf OpenWrt auf. Die Namensgeberin Kathleen Booth entwickelte 1948 die Assembler-Sprache für den Automatic Relay Computer ARC.

Inhaltsverzeichnis

Unterstützte Hardware

WLAN-Router

Router mit nur 4MB Flash und/oder nur 32MB RAM werden für Berlin nicht empfohlen.
Du suchst eine einfache Entscheidungshilfe? Siehe Frage Welche günstigen Router kann ich benutzen?.

Gerät Freq. (Ghz) Preis Typ CPU/RAM/Flash Antenne Ethernet PoE USB Firmware
Ubiquiti NanoStation M2[1][2] 2.4 ca. 55€ outdoor 400 / 32 / 8 Sektor 2*100MBit ja 1*in 1*out nein Router-Version: XM / XW
Ubiquiti NanoStation loco M2[1][2][3] 2.4 ca. 50€ outdoor 400 / 32 / 8 Sektor 1*100MBit ja 1*in nein Router-Version: XM / XW
Ubiquiti NanoStation M5[1][2] 5 ca. 85€ outdoor 400 / 32 / 8 Sektor 2*100MBit ja 1*in 1*out nein Router-Version: XM / XW
Ubiquiti NanoStation loco M5[1][2][3] 5 ca. 65€ outdoor 400 / 32 / 8 Sektor 1*100MBit ja 1*in nein Router-Version: XM / XW
Ubiquiti PicoStation M2[2] 2.4 ca. 75€ outdoor 400 / 32 / 8 Omni 1*100MBit ja 1*in nein Download
Ubiquiti Bullet M2[2] 2.4 ca. 75€ outdoor 400 / 32 / 8 - 1*100MBit ja 1*in nein Download
Ubiquiti Unifi AP (LR) 2.4 ca. 60/80 indoor 400 / 64 / 8 Omni 1*100MBit ja 1*in nein Download
Ubiquiti Unifi AP Pro 2.4 / 5 ca. 190€ indoor 560 / 128 / 16 Omni 2*1GBit ja 1*in 1*out nein Download
TP-Link WR841N(D) v3.x-9.x[4][2] 2.4 - indoor 400-550 / 32 / 4 Omni 5*100MBit nein nein Router-Version: v3.x / v5.x / v7.x / v8.x / v9.x
TP-Link WR841N(D) v10.x/v11.x[4][2][5] 2.4 ca. 15€ indoor 650 / 32 / 4 Omni 5*100MBit nein nein Router-Version: v10.x / v11.x
TP-Link WR842ND v2.x[2][6] 2.4 ca. 25€ indoor 535 / 32 / 8 Omni 5*100MBit nein 1*USB2.0 Download
TP-Link WR842N v3.x[6] 2.4 ca. 25€ indoor 650 / 64 / 16 Omni 5*100MBit nein 1*USB2.0 Download
TP-Link WR1043ND v1.x[7] 2.4 - indoor 400 / 32 / 8 Omni 5*1GBit nein 1*USB2.0 Router-Version: v1.x
TP-Link WR1043ND v2.x/v3.x/v4.x 2.4 ca. 45€ indoor 720 / 64 / 8 Omni 5*1GBit nein 1*USB2.0 Router-Version: v2.x / v3.x / v4.x
TP-Link WDR3500 v1.x[8] 2.4 / 5 - indoor 560 / 128 / 8 Omni 5*1GBit nein 1*USB2.0 Download
TP-Link WDR3600 v1.x[8] 2.4 / 5 - indoor 560 / 128 / 8 Omni 5*1GBit nein 1*USB2.0 Download
TP-Link WDR4300 v1.x[8] 2.4 / 5 - indoor 560 / 128 / 8 Omni 5*1GBit nein 1*USB2.0 Download
TP-Link WDR4900 v1.x[8] 2.4 / 5 - indoor 800 / 128 / 16 Omni 5*1GBit nein 2*USB2.0 Download
TP-Link Archer C7 v2.x 2.4 / 5 ca. 85€ indoor 720 / 128 / 16 Omni 5*1GBit nein 1*USB2.0 Download
TP-Link Archer C5 v1.x 2.4 / 5 ca. 70€ indoor 720 / 128 / 16 Omni 5*1GBit nein 1*USB2.0 Download
TP-Link CPE210 v1.0 / v1.1[1][5] 2.4 ca. 40€ outdoor 560 / 64 / 8 Sektor 2*100MBit ja 1*in 1*out nein Download
TP-Link CPE510 v1.0 / v1.1[1] 5 ca. 50€ outdoor 560 / 64 / 8 Sektor 2*100MBit ja 1*in 1*out nein Download
GL-AR150 2.4 ca. 25€ indoor 400 / 64 / 16 Omni 2*100MBit optional 1*USB2.0 Download
GL.iNet6408A v1 2.4 - indoor 400 / 64 / 8 Omni 2*100MBit nein 1*USB2.0 Download
GL.iNet6416A v1 2.4 ca. 20€ indoor 400 / 64 / 16 Omni 2*100MBit nein 1*USB2.0 Download
D-Link DIR-505 2.4 ca. 25€ indoor 400 / 64 / 8 Omni 1*100MBit nein 1*USB2.0 Download
Nexx WT3020 H / F / AD[9] 2.4 ca. 15€ indoor 580 / 64 / 8 Omni 2*100MBit nein 1*USB2.0 Download
Mikrotik RB411 1 x miniPCI ab. 45€ indoor 300 / 64 / 32 - 1*100MBit nein - Download
  1. 1,0 1,1 1,2 1,3 1,4 1,5 Die Netzwerk-Ports sind etwas speziell belegt; am LAN/PoE-Port liegt Freifunk-DHCP an. Eine Verbindung zum Uplink-Router benötigt eine Umkonfiguration (siehe Issue 292). Achtung: Schließt man den Uplink-Router an LAN an, besteht direkter Zugriff auf das LAN von Freifunk aus.
  2. 2,0 2,1 2,2 2,3 2,4 2,5 2,6 2,7 2,8 Aufgrund der schwachen RAM-Ausstattung empfiehlt es sich, nicht benötigte Dienste (monitor.berlin.freifunk.net) abzuschalten.
  3. 3,0 3,1 Bei den loco XW-Geräten "verschwindet" der LAN-Port ab und zu, siehe hier.
  4. 4,0 4,1 Der Router besitzt lediglich 4MBytes FlashROM, weswegen einige Dinge weggelassen werden mussten. U.a. fehlen die monitor.berlin.freifunk.net-Statistiken (collectd). Sollte das Router-UI keine Änderungen mehr annehmen, ist vermutlich das Flash voll; in dem Fall muss der Router komplett zurückgesetzt werden. Es ist nicht sicher, ob dieser Router in Zukunft weiterhin unterstützt wird.
  5. 5,0 5,1 Es gibt hier aktuelle Modelle, die ein "EU" im Modellnamen tragen. Diese werden z.Zt. nur von Vorserien-Firmware unterstützt.
  6. 6,0 6,1 Bei Kauf auf genaue Revision achten, wird in Shops oft falsch ausgezeichnet. Der 842v2 hat immer abnehmbare Antennen (ND), der 842v3 immer feste Antennen (N) - und nicht mit dem 841 verwechseln.
  7. Diese Hardwareversion ist bekannt für Probleme beim Wifi-Interface, wenn viele (>20) Clients verbunden sind.
  8. 8,0 8,1 8,2 8,3 Evtl. sind die Stellungen des Wifi on/off-Schalters vertauscht (Schalter auf "off"=WLAN an).
  9. Der Nexx WT3020A (das ist die Variante ohne USB-Port) wird nicht unterstützt.

CoreRouter

In bestimmten Setups wie BBB-Standorten oder größeren zentralen Installationen kann es sinnvoll sein, einen zentralen dedizierten Router mit schnellen Netzwerk-Interfaces und schneller CPU (für VPN) einzusetzen. Dieser Router benötigt nicht unbedingt eigene WiFi-Interfaces, sondern nutzt weitere angeschlossene WiFi-Hardware (NanoStations, Powerbeams oder CPEs), die autonom einen Link aufbaut.

Eine Zusammenfassung solcher Geräte findest du im Artikel Berlin:CoreRouter.

Hinweise zur Firmware

Releases

Kathleen 0.3.0, 2017-04-10
README, CHANGELOG, alle Firmware-Images, Announcement
Kathleen 0.2.0, 2016-11-27
README, CHANGELOG, alle Firmware-Images, Announcement
Kathleen 0.1.2, 2015-07-02
README, CHANGELOG, alle Firmware-Images, Announcement
Kathleen 0.1.1, 2015-05-30
README, CHANGELOG, alle Firmware-Images, Announcement
Kathleen 0.1.0, 2015-02-19
README, CHANGELOG, alle Firmware-Images, Announcement
Router mit 4MB Flash (insbesondere WR841) werden von dieser Version nicht unterstützt.
#217 (s.u.) ist nicht richtig gefixt.
Kathleen 0.0.0, 2014-10-29
README, CHANGELOG, alle Firmware-Images, Announcement
#191: Auf Routern mit 4MB Flash (u.a. TP-Link WR841) läuft das Dateisystem schnell voll, Rekonfiguration mit "Save&Apply" funktioniert dann nicht.
#217: Monitoring/collectd macht wenigstens in einigen Setups Probleme (Speicherleck, Reboots des Routers alle paar Stunden). Bei Routern mit nur 32MB RAM (TP-Link WR842, WR1043 v1) das Monitoring am besten abschalten.

Image-Typen

Die Firmware gibt es in verschiedenen Varianten, die sich in den installierten Software(-Packages) unterscheiden. Etwas dazu steht im README, aber hier schonmal die wesentlichen Infos.

default
Das "Standard-Image", wie es auch das Howto beschreibt.
Inklusive Einrichtungsassistent und VPN (und B.A.T.M.A.N. ggf. zur manuellen Einrichtung).
default_4MB
Ebenso "Standard-Image", aber für die Router mit nur 4MB Flash.
Einige Packages mussten weggelassen werden, u.a. collectd (die Statistiken in monitor.berlin.freifunk.net fehlen also) und BATMAN.
backbone
Das Image für die, die manuell Konfigurieren wollen und kein VPN brauchen.
Der Einrichtungsassistent und OpenVPN fehlen, dafür sind mehr Debugging-Netzwerktools verfügbar.
backbone_4MB
Wie "backbone", aber ohne collectd, dafür mit B.A.T.M.A.N..

Häufige Fragen

Fragen allgemein zu Freifunk werden auf den FAQ-Seiten beantwortet.

Die Berliner Mailingliste bzw. ihr Archiv (via Google durchsuchen, durchsuchbares Archiv auf gmane) beantwortet auch viele Fragen.

Ich sehe zwar das WLAN "berlin.freifunk.net", komme darüber aber nicht ins Internet. Woran liegt das?

Dafür gibt es mehrere mögliche Gründe:

  • Die Verbindungqualität ist zu schlecht/die Entfernung zum Knoten ist zu groß.
  • Der Knoten hat zur Zeit selbst keine Internet-/Mesh-Verbindung.
  • Der Knoten ist überlastet:
    • Durch die WLAN-Technik bedingt kann ein einzelner Knoten nur ein paar dutzend Geräte bedienen, unabhängig von der Bandbreite, mit der er angebunden ist.
    • Eventuell sind dem Knoten die zur Verfügung stehenden Freifunk-IPs ausgegangen. Das kann der Administrator des Knotens beheben - Nachfragen schadet nichts.
  • Sollten mehrere Knoten in der Nähe sein, bist du vielleicht vom Einzugsbereich eines Knotens in den eines anderen Knotens geraten. Einige Standorte unterstützen dieses sogenannte Roaming jedoch nicht. Der Effekt ist dann, dass dein Gerät zwar im WLAN eingebucht ist, jedoch seine Netzwerkkonfiguration "veraltet" ist und die Daten ins Nirvana fließen. Einfach das WLAN kurz aus- und wieder anstellen hilft dann.

Was bringt es mir, einen Freifunk-Knoten bei mir zuhause aufzustellen?

Falls du schon z.B. von einem Nachbarn berlin.freifunk.net siehst, bringt es für dich einmal eine stabilere Verbindung; die Möglichkeit, Geräte auch über Netzwerkkabel anzuschließen; und schließlich fungiert jeder Freifunk-Knoten gewissermaßen auch als "Repeater", d.h. dieser Knoten vergrößert die Reichweite des Freifunk-Netzwerks.

Bekommst du zuhause noch kein Freifunk, hast aber bereits einen Internet-Zugang per DSL o.ä., so bekommst du mit einem eigenen Freifunk-Router ein hervorragendes WLAN für Gäste und Nachbarn.

Ich sehe ein Freifunk-WLAN. Wie finde ich heraus, wo der zugehörige Router steht?

Eventuell ist der Knoten auf openwifimap.net bzw. Hopglass eingetragen. Dort finden sich evtl. auch Kontaktinformationen des Betreibers des Knotens.

Falls du dich in das WLAN einloggen kannst, kannst du auch die Webseite des Routers aufrufen, auf der sich evtl. Informationen finden. Dazu musst du, nachdem du dich eingeloggt hast, im Browser auf http://frei.funk/ gehen. Sollte das nicht funktionieren, musst du die IP deines aktuellen Netzwerk-Gateways herausfinden und sie im Browser aufrufen (wie z.B. http://10.230.6.7/).

Zuguterletzt kannst du auch einfach auf der Mailingliste nachfragen.

Was hat es mit den SSIDs "intern-chXX.berlin.freifunk.net" auf sich?

Das sind die internen WLAN-Netze, über die die Knoten untereinander im Mesh Daten austauschen. Endgeräte ohne entsprechende Software (in Berlin meist OLSRv1) können und sollten sich mit diesen WLANs nicht verbinden.

Was leistet ein normaler Knoten mit der Berliner Freifunk-Firmware?

Er kann Verbindung zum Freifunk-Mesh herstellen; für normale Clients wie Smartphones und Notebooks erscheint der Knoten wie ein normaler Access Point.

Sollte bereits eine Internet-Verbindung via DSL o.ä. zur Verfügung stehen, kann der Knoten dieses im Mesh freigeben, wobei die freigegebene Bandbreite begrenzt werden kann. Sämtlicher Freifunk-Datenverkehr wird via Vpn03 über IPs des Fördervereins Freie Netzwerke geleitet (vgl. Störerhaftung, weitere Infos auf freifunkstattangst.de).

An den LAN-Ports des Routers liegt normalerweise Freifunk-Netz an.

Der Freifunk-Router ist in der normalen Konfiguration "hinter" den normalen DSL-/Kabel-Router anzuschließen; ein Zugriff aus dem Freifunk-Netz auf das Heimnetz ist nicht möglich.

Mit etwas manueller Konfiguration lässt sich ein Freifunk-Knoten gleichzeitig als normaler Haus-Router benutzen, sofern ein dediziertes DSL-/Kabelmodem vorhanden ist. Eine Anleitung dazu gibt es hier.

Die FAQ Technik geht auch noch allgemeiner auf diese Frage ein.

Mein Router erscheint auf der Freifunk-Übersichtskarte nicht bzw. ich möchte ihn wieder löschen, wie geht das?

Der Knoten erscheint auf openwifimap.net bzw. Hopglass, sofern bei der Ersteinrichtung Koordinaten eingetragen wurden und der Router ca. eine Stunde mit Internet-Verbindung lief.

Knoten, die mehr als eine Woche ohne Internet-Verbindung blieben, werden aus der Karte wieder gelöscht; aus dem Monitor verschwinden sie nach rund einem Monat.

Wie läuft das Firmware-Update eines bereits mit der Berliner Freifunk-Firmware ausgestatteten Routers?

Einfach das passende Firmware-Image herunterladen (die "sysupgrade"-Variante), in das Router-Webfrontend als Admin einloggen und das Image per "System / Backup/Flash Firmware", "Flash new firmware image" einspielen. Wenn das entsprechende Häkchen gesetzt ist, bleiben die alten Einstellungen erhalten.

Für Kommandozeilen/SSH-Leute: Image z.B. per wget nach /tmp herunterladen und per sysupgrade flashen. Per Default bleiben /etc/config/* und einige weitere ausgewählte Dateien (Details) erhalten; alle selbst nachinstallieren Packages oder Dateien an anderen Stellen im Dateisystem gehen verloren.

Netzwerk

Nehmen mir die Freifunker nicht meine Bandbreite weg, wenn ich mein Internet freigebe?

In der Berliner Firmware wird konfiguriert, wieviel Bandbreite für Freifunk freigegeben werden soll. Alternativ kannst du im Haupt-Router (der "vor" dem Freifunk-Router) den Freifunk-Router eine geringere Priorität geben; dadurch hast du immer volle Bandbreite, gleichzeitig können die Freifunker aber auch die volle Bandbreite nutzen, wenn du sie gerade nicht brauchst. In der Praxis stellt allerdings sowieso zur Zeit das Freifunk-VPN einen Flaschenhals dar - siehe weiter unten. Freifunk kann entsprechend sowieso nur die kleinsten erhältlichen DSL-Anschlüsse "saturieren".

Welche Technologie benutzt das Mesh?

Das Berliner Backbone (BBB) ist eins der ersten Freifunk-Netzwerke und benutzt größtenteils OLSRd v1. Größere Standorte benutzen häufig zusätzlich B.A.T.M.A.N., um den WLAN-Clients wenigstens innerhalb der Standort-Knoten Roaming zu ermöglichen. Die Parameter für das Adhoc-Mesh sind:

  • 2.4GHz: Kanal 13, BSSID D2:CA:FF:EE:BA:BE, SSID "intern-ch13.freifunk.net"
  • 5GHz: Kanal 36, BSSID 02:36:CA:FF:EE:EE, SSID "intern-ch36.freifunk.net"

Es gibt noch einige weitere Standorte, die mit den PBerg-Parametern laufen (Kanal 10, BSSID 02:CA:FF:EE:BA:BE). Einige Standorte experimentieren Stand Mitte 2015 mit 802.11s.

Viele Standorte nutzen das Core-Router-Setup, d.h. an einem sogenannten "Core-Router" (auf dem insbesondere OLSRd läuft) hängen per LAN angeschlossene weitere Router, die aber nur als reine Antennen/Bridges benutzt werden und auf denen typischerweise die Hersteller-Firmware läuft. Das ist unter anderem nötig, weil für die 5GHz-Richtfunkverbindungen DFS vorgeschrieben ist, das aber von OpenWrt/der Freifunk-Firmware nicht unterstützt wird. DFS ist auch der Grund, weswegen die Richtfunkverbindungen zwischen Standorten häufig nicht im Adhoc-Modus, sondern via AP<->Client laufen; Adhoc unterstützt kein DFS. Solltest du dich mit einem Standort verbinden wollen, der als Client-Seite einer solchen Verbindung läuft, musst du dich mit dem Standortbetreiber in Verbindung setzen und eine Lösung suchen.

Wieso müssen IPs und VPN-Zugang gesondert beantragt werden? In anderen Communities ist das einfacher!

Viele andere Communities benutzen Gluon bzw. damit B.A.T.M.A.N. und fastd. Mit dieser Technik wird ein einzelnes verbundenes Layer 2-Netz (MAC-Ebene) aufgespannt. Das hat Vorteile, aber auch Nachteile - teilweise technischer, teilweise politischer Natur.

  • Einige Dienste (VPN, DHCP) müssen von einer zentralen Stelle angeboten werden
  • BATMAN skaliert nicht zu sehr großen Netzen (ohne weiteres) - siehe auch dieses Posting

In Berlin war/ist es den Freifunkern wichtig, keine zentralisierte Infrastruktur aufzubauen:

  • Das VPN ist frei wählbar (man kann das VPN03 nehmen, aber auch andere VPNs sind möglich)
  • IPs sind prinzipiell frei wählbar (die Registrierung dient nur dazu, doppelt belegte IPs zu vermeiden)
  • Lokale abweichende Installationen sind möglich (siehe z.B. "Kiez-Setup" im Artikel BATMAN-Konfiguration)

Wenn du eine einfachere Lösung z.B. für dein Kiez anbieten möchtest, vielleicht auch auf Gluon-Basis, nimm' Kontakt mit den anderen Berliner Freifunkern auf.

Außerdem ist ein vereinfachter Einrichtungsassistent in Arbeit, der IP/VPN-Konfiguration auch mit wenigen Clicks ermöglichen soll.

Ist das Netz abhörsicher?

  • Die Verbindung von Clients zu Freifunk-Knoten ist unverschlüsselt (offener AP).
  • Die Verbindung der Freifunk-Knoten untereinander erfolgt unverschlüsselt.
  • Die Verbindung von Freifunk-Knoten, die per DSL/Kabel an das Vpn03 angeschlossen sind, ist - trotz des Stichworts "VPN" - unverschlüsselt, da die Router zuwenig Rechenleistung für hohen Durchsatz haben, das Rechenleistung auf Seiten des Servers einspart und bereits die Teilstrecken vorher unverschlüsselt waren.

Da fast alle Webseiten heutzutage HTTPS benutzen (es empfiehlt sich die Benutzung von HTTPS Everywhere), lassen sich trotzdem keine Inhaltsdaten ("Was wurde von meinem Browser angezeigt; was habe ich in Web-Formularen eingegeben") von Dritten mitlesen. Verbindungsdaten ("Mit welchem Server bin ich gerade in Kontakt") sind jedoch auch mit HTTPS nicht gesichert. Wer z.B. über Freifunk Verbindung zu einem Firmen-VPN oder anderem verschlüsselten VPN aufbaut, ist komplett abhörsicher.

Grundlegende Hinweise zum sicheren Umgang mit dem Rechner in offenen Netzen bzw. im Internet sind im Artikel Sicherheit nachzulesen.

Ist mein privates Netz sicher vom Freifunk-Netz abgetrennt?

Durch Nutzung von Policy Routing stellt die Berliner Firmware sicher, dass der Traffic, der von Clients im Freifunknetz kommt, nicht an das über den WAN-Port angeschlossene Netzwerk geroutet wird. Dadurch ist für Freifunk-Clients nur Zugriff auf andere Mesh-Router oder auf das Internet via VPN möglich.

Direkt auf dem Freifunk-Router installierte eigene Dienste und auch ggf. der per Konsole eingeloggte Administrator nutzen direkt das Netzwerk am WAN-Port.

Ein einfacher Test, ob die Trennung von Freifunk und privatem LAN auch korrekt funktioniert, ist im Artikel Sicherheit beschrieben. Insbesondere bei größeren manuellen Konfigurationsänderungen ist dieser Test empfehlenswert.

Allgemeine Hardwarefragen

Kann ich den Router XYZ/den alten Linksys WRT54G mit der aktuellen Firmware benutzen?

Es werden die Router unterstützt, die auf dieser Seite oben in der Tabelle aufgeführt sind.
Empfehlenswert wiederum sind davon nur Geräte mit 8MB Flash und >=64MB RAM. Insbesondere mit AVM-Geräten (Fritz-Boxen) läuft die Berliner Firmware nicht, da bereits ihre Grundlage OpenWrt diese Geräte nicht unterstützt. Der alte WRT54G bietet mit nur 16MB RAM deutlich zu wenig Ressourcen, außerdem unterstützt seine WLAN-Hardware VAPs nicht, könnte also nur Meshen (und das auch nur mit 802.11g und nicht 802.11n) und nicht parallel einen Access Point anbieten.

Eine Übersicht der Hardware gibt es unter:

Welche günstigen Router kann ich benutzen?

Seit einiger Zeit gibt es den TL-WR842ND v3 (nicht verwechseln mit dem 841 oder den älteren Versionen), dieser bietet 2.4GHz und 64MB RAM und 16MB Flash für rund 30€. Mit dieser Hardwareausstattung ist es ein sehr guter Indoor-Router für den 2.4GHz-Bereich. Er ist allerdings schlecht zu bekommen; es existiert aber ein kleiner Vorrat, einfach auf der Mailingliste nachfragen.
In Deutschland besser erhältlich sind die älteren Varianten 842v1 und v2, die allerdings nur 32MB RAM und 8MB Flash haben. Die 32MB RAM können etwas knapp werden, am besten die Web-Statistiken abschalten.

Weiterhin unterstützt die Berliner Firmware u.a. den GL-AR150 (ca. 22€, 16MB Flash) und den Nexx WT3020H (ca. 12€, 8MB Flash; nicht die A-Variante!). Beide bieten 64MB RAM, 1x USB, unterstützen (nur) 2.4GHz und werden per Micro-USB (5V, 2A) mit Strom versorgt. Der AR-150 bietet optional sogar PoE und eine externe Antenne. Der WT3020 ist nicht so gut verfügbar (muss ggf. im Ausland bestellt werden), bisher wenig getestet und hat nur interne Antennen.
Außerdem wird der D-Link DIR-505 (ca. 16€) unterstützt, der direkt in eine Steckdose gesteckt werden kann. Nachteile: Nur interne Antenne, nur 2.4GHz, nur ein LAN-Port, D-Link.

Für Berlin nicht empfehlenswert ist der TL-WR841. Nach ihm wird gerne gefragt, wohl weil er günstig verfügbar ist. Er wird von der Berliner Firmware unterstützt, aber seine 4MB Flash sind randvoll, auch wenn schon z.B. das Monitoring weggelassen wurde. Andere Communities haben diese Probleme nicht, insbesondere auch da ihre Router typischerweise nur das Minimum-LuCI mitbringen, die Berliner Firmware aber (fast) das komplette Admin-Benutzerinterface mitbringt. Außerdem sind auch seine 32MB RAM je nach Konfiguration recht eng. Besorgt euch lieber den 842, der hat genug ROM und außerdem auch USB.

Services im Freifunk-Netz

Ich möchte mir Freifunk-interne Dienste ansehen, aber mein Freifunk-Router zeigt keine an. Warum?

Vermutlich ist dein Router nicht per WLAN-Mesh mit anderen Freifunk-Knoten verbunden. Über das VPN03 läuft tatsächlich nur der Internet-Datenverkehr der Freifunk-Clients an deinem Knoten; über das VPN03 liegt kein Mesh an. Du musst Dir zusätzlich das BBB-VPN (manuell) einrichten.

Ein Überblick der verschiedenen im Zusammenhang mit Freifunk relevanten VPNs (angepasst aus diesem Posting):

VPN03
Sinn und Zweck: reine anti-Störerhaftung, nichts anderes.
Wird auch von anderen Communities als Berlin benutzt.
Prinzipiell sollte es möglich sein/bleiben, auch andere VPN-Anbieter zum Angehen der Störerhaftungs-Problematik zu benutzen.
Einzelne Instanzen des VPN03 können/werden außerhalb von Berlin betrieben.
Wird abgeschaltet, sobald die Störerhaftung weg ist.
Routing: OpenVPN (+ iroute hack, kudos Sven-Ola)
BBB-VPN
Sinn und Zweck: Anbindung von nur via DSL/Kabel angebundenen "Inseln" ans BBB - nicht ins Internet. Einrichtung manuell.
Routing: OLSR
IC-VPN
Sinn und Zweck: Freifunk-Community-InterConnect. Funktioniert nur im BBB. Für Endanwender normalerweise nicht relevant.
Routing: Tinc Layer2 und BGP für Layer3

Wie kann ich einen eigenen Service erstellen?

Für die Erstellung eines Services gibt es grundsätzlich verschiedene Möglichkeiten. Hier das Beispiel für eine WebCAM mit WLAN:

  • Voraussetzung: Der DHCP vergibt Adressen ohne maskerading, also aus dem Freifunk-IP-Raum (10.230.0.0).
  • WebCam (google: netcam belkin wlan) am WLAN berlin.freifunk.net einwählen lassen.
  • Am AccessPoint unter Administrator-> Netzwerk-> "DHCP and DNS" der WebCAM die momentane IP als statische IP zuordnen.
  • Am AccessPoint unter Administrator-> Services-> OLSR(4)-> HNA-> Plugins-> olsrd-nameservice-xxx-> Edit

äquivalete Einträge hinzufügen:

    • services-file:
      /var/run/services_olsr
    • service:
      http://10.230.4.21:80|tcp|MrFish
      • bedeutet:
        http(s)://<URL>|tcp bzw. udp|Bezeichnung

Das sollte die einfachste Variante gewesen sein. Eine Weitere Variante wäre eine verkabelte CAM: Die Variante ist etwas schwieriger. Hier ist die IP-Adresse zu beachten. Möglicherweise gibt es keinen DHCP auf dem LAN. Möglicherweise muss man eine HNA setzen. Möglicherweise muss man eine statische Route setzen.

VPN

Per Default ist in der Firmware die Nutzung des VPN03 vorgesehen. Wenn du ein anderen VPN-Anbieter nutzen willst oder auf das VPN komplett verzichten willst, ist manuelle Konfiguration nötig.

Ich bekomme über meinen Freifunk-Knoten nur unter 5MBytes pro Sekunde, obwohl ich deutlich mehr freigegeben habe, warum?

OpenVPN schafft auf den meisten Routern leider keinen höheren Durchsatz. In manchen Fällen kann es auch helfen, die Bandbreiten-Begrenzung auf der Kommandozeile per /etc/init.d/qos disable ; reboot ganz abzuschalten.

Vermutlich wird irgendwann eine Alternative zu OpenVPN angeboten werden (Performance-Vergleich siehe hier), aber besser nicht die Luft anhalten.

Spezielle Konfigurationen

Warum funktioniert mein Freifunk-Router nicht, wenn er an den Gastzugang des Haupt-Routers angeschlossen wurde?

Schließt man den Freifunk-Router an den Gastzugang z.B. einer FritzBox an, müssen ein paar Ports freigegeben werden, siehe dieses Posting.

Allerdings gibt es Nachteile beim Betreiben des FF-Routers am Gastzugang, so ist z.B. das Web-Interface des FF-Routers so nicht aus dem LAN erreichbar, außerdem funktioniert der ggf. eingerichtete "Private AP" des Freifunk-Routers nicht richtig, da er eben nicht das LAN erweitern kann, sondern nur zum Gastzugang führt - auf jeden Fall sollte also eine Gast-SSID für den privaten AP gewählt werden.

Im Zweifelsfall kann der FF-Router einfach an einen LAN-Port gehängt werden; durch Policy Routing ist ein Zugriff auf das LAN vom FF-Netzwerk aus nicht möglich.

Kann ich meinen Freifunk-Knoten per WLAN mit meinem privaten WLAN-Router verbinden?

Normalerweise muss ein Kabel vom privaten Router zum WAN-Port des Freifunk-Knotens gezogen werden, wenn man den eigenen Internet-Zugang freigeben will. Das WLAN des Freifunk-Knotens kann sich nicht mit dem privaten WLAN verbinden, u.a. da die WLAN-Hardware nur auf einem Kanal laufen kann und das Heimnetzwerk nicht unbedingt auf Kanal 13 läuft.

Es gibt mehrere Möglichkeiten zur Lösung des Problems.

Freifunk-Router mit einem zusätzlichen WLAN-USB-Stick ausstatten
Eine Anleitung dafür gibt es hier - das ath9k_htc-Kernel-Modul ist ab Kathleen 0.1.1 verfügbar.
Evtl. wird der reghack nötig (neuer reghack ab Kathleen 0.2.0), falls durch das neue Modul auf einmal Kanal 13 nicht mehr verfügbar ist (siehe iw list).
Vorteil dieser Lösung: Günstig. Nachteil: Konfigurationsaufwand; Konfiguration geht nach Firmware-Updates eventuell kaputt und muss wiederholt werden.
Den WAN-Port des Freifunk-Routers mit einem anderen Router, der im Client Mode läuft, verbinden
Diverse einfache Router (z.B. ein paar der TP-Links) können mit der Original-Firmware im Client Mode betrieben werden, können sich also in ein bestehendes WLAN als Client einloggen und das Netz an ihrem LAN-Port zur Verfügung stellen.
Diesen LAN-Port kann man dann mit dem WAN-Port des Freifunk-Routers verbinden.
Vorteil dieser Lösung: Robust, auch bei Firmware-Upgrades des Freifunk-Routers. Nachteil: Weiterer Router nötig; Stromverbrauch.
Zwei FF-Router benutzen, zwischen diesen meshen
Hierbei wird ein FF-Router direkt (per LAN) an den Haupt-Router angeschlossen; der andere FF-Router verbindet sich per WLAN-Meshing mit dessen FF-WLAN (nicht mit dem verschlüsselten privaten WLAN).
Vorteil dieser Lösung: Keine Spezialkonfiguration nötig, weitere Abdeckung durch FF-WLAN. Nachteil: Weiterer Router nötig; Stromverbrauch.

Ich brauche weitere IP-Adressen für mein DHCP bzw. für das weitere Interface meines neuen Dual Band-Routers, wie bekomme ich die?

Im "Expertenmodus" von config.berlin.freifunk.net lassen sich sowohl IP-Ranges als auch einzelne IPs besorgen.

  • IPv4-Präfix 32 gibt eine einzelne IP
  • IPv4-Präfix 28 gibt 14 nutzbare IPs (Standard des normalen Wizards für Wohnungs-Router)
  • IPv4-Präfix 27 gibt 30 nutzbare IPs (Standard für "Café-Router")

Brauchst du nur eine weitere IP für das weitere Interface eines Dual Band-Routers, einfach eben die eine zusätzliche IP beantragen. Willst du den DHCP-Range vergrößern, am besten alle Freifunk-IPs des Routers mit dem Link aus der alten Mail zurückgeben und neue IPs holen.

Die neuen IP-Adressen sind dann an folgenden Stellen zu ändern:

  • Netzwerk --> Schnittstellen
    • DHCP, Wireless0, ggf. Wireless1
  • Netzwerk --> Rechnernamen
    • frei.funk
  • Dienste --> OLSR IPv4
    • Registerkarte "HNA-Ankündigungen"

Ich betreibe mehrere Freifunk-Knoten dicht beieinander. Was sollte ich beachten?

Generell lässt sich sowohl hier im Wiki bei der Standort-Doku als auch in den router-configs auf GitHub spicken.

Verbindung der lokalen Knoten per LAN-Mesh

Das entlastet das WLAN.

Ein Schritt für Schritt Tutorial mit Bildern: Berlin:Tutorial:Mesh_via_LAN

Dazu ist etwas manuelle Konfiguration nötig, da OLSRd 1 auf jedem Interface, auf dem gemesht werden soll, eine eigene IP braucht - einfaches Bridging der Interfaces ist nicht möglich. Die Konfiguration davon läuft in etwa wie folgend. Eine (mäßig verständliche) Erklärung zur VLAN-Konfiguration in OpenWrt gibt es im Artikel "Switch" im OpenWrt-Wiki.

Eine bessere Erklärung gibt es "hier".

Unter Luci würde ich folgendes empfehlen:

  • Unter Network/Switch ein VLAN am LAN-Switch abspalten, siehe "hier"
  • Unter Network/Interface eine IP-Adresse vergeben, entweder ein /16 oder nach Bedarf auch ein /32er Netz aus dem Berliner Freifunk-Adressbereich
  • Unter /Service/olsrv4 dieses neue Interface hinzufügen
/etc/config/network

# Das "LAN"-Interface, typischerweise DHCP-Server mit Freifunk-IPs.
config interface 'lan'
        option ifname 'eth0.1'
        ...

# Das "WAN"-Interface, typischerweise DHCP-Client an DSL-/Kabelmodem.
config interface 'wan'
        option ifname 'eth0.2'
        ...

# Das Interface zum LAN-Meshing mit anderen Knoten. Statisch auf eine Freifunk-IP konfiguriert.
config interface 'lanmesh'
        option ifname 'eth0.3'
        option ipaddr '...'
        option netmask '...'
        option proto 'static'

# VLAN-Handling für eth0 anschalten
config switch
        option enable_vlan '1'
        option name 'eth0'
        option reset '1'

# eth0.1=lan auf physikalischen Ports 3-5
config switch_vlan
        option device 'eth0'
        option ports '0t 3 4 5'
        option vlan '1'

# eth0.2=wan auf physikalischem Port 1
config switch_vlan
        option device 'eth0'
        option ports '0t 1'
        option vlan '2'

# eth0.3=lanmesh auf physikalischem Port 2
config switch_vlan
        option device 'eth0'
        option ports '0t 2'
        option vlan '3'

/etc/config/olsrd

config Interface
        option Mode 'ether'
        option ignore '0'
        option interface 'lanmesh'

Roaming auf den DHCP-Interfaces unterstützen

Auf den DHCP-Interfaces der Knoten sollte möglichst B.A.T.M.A.N. eingerichtet sein, damit Roaming der Clients zwischen den Knoten funktioniert. Sollte das zu aufwendig sein, am besten die SSID der Freifunk-APs abweichend vom Default berlin.freifunk.net setzen, z.B. berlin.freifunk.net/#KnotenName, damit die Clients nicht roamen.

Wie kann ich WLAN-Clients nach dem Login eine das Projekt erklärende Seite ("Splash-Screen") zeigen?

Das dafür zuständige Paket luci-app-splash ist nicht in der Firmware oder den vorkonfigurierten opkg-Quellen enthalten. Ein experimenteller Workaround ist, der Datei /etc/opkg.conf folgendes hinzuzufügen:

src/gz barrier_breaker_base http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/base
src/gz barrier_breaker_oldpackages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/oldpackages
src/gz barrier_breaker_packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/packages
src/gz barrier_breaker_luci http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/luci/

Wie priorisiere ich bestimmte Verbindungen im Netzwerk?

Mit der LinkQualityMult-Option des OLSRd lassen sich bestimme Verbindungen künstlich verbessern bzw. verschlechtern. Ein Auszug aus der OLSR-Konfiguration olsrd.conf findet man auf GitHub.