Berlin:FAQ

Aus wiki.freifunk.net
Zur Navigation springen Zur Suche springen


Inhaltsverzeichnis

Häufige Fragen

Neben den folgenden Antworten ist auch die Berliner Mailingliste bzw. ihr Archiv (via Google durchsuchen) eine gute Informationsquelle.

Worum geht es bei Freifunk? Wo finde ich Infos?

Allgemeine Fragen zu Freifunk werden auf den FAQ-Seiten hier im Wiki bzw. direkt auf Freifunk.net beantwortet.
Außerdem gibt es natürlich die Möglichkeit, auf einer der Berliner Mailinglisten Fragen zu stellen oder zu einem der Treffen zu kommen.

Ich sehe zwar das WLAN "berlin.freifunk.net", komme darüber aber nicht ins Internet. Woran liegt das?

Dafür gibt es mehrere mögliche Gründe:

  • Die Verbindungqualität ist zu schlecht/die Entfernung zum Knoten ist zu groß.
  • Der Knoten hat zur Zeit selbst keine Internet-/Mesh-Verbindung.
  • Der Knoten ist überlastet:
    • Durch die WLAN-Technik bedingt kann ein einzelner Knoten nur ein paar dutzend Geräte bedienen, unabhängig von der Bandbreite, mit der er angebunden ist.
    • Eventuell sind dem Knoten die zur Verfügung stehenden Freifunk-IPs ausgegangen. Das kann der Administrator des Knotens beheben - Nachfragen schadet nichts.
  • Sollten mehrere Knoten in der Nähe sein, bist du vielleicht vom Einzugsbereich eines Knotens in den eines anderen Knotens geraten. Einige Standorte unterstützen dieses sogenannte Roaming jedoch nicht. Der Effekt ist dann, dass dein Gerät zwar im WLAN eingebucht ist, jedoch seine Netzwerkkonfiguration "veraltet" ist und die Daten ins Nirvana fließen. Einfach das WLAN kurz aus- und wieder anstellen hilft dann.

Was bringt es mir, einen Freifunk-Knoten bei mir zuhause aufzustellen?

Falls du schon z.B. von einem Nachbarn berlin.freifunk.net siehst, bringt es für dich einmal eine stabilere Verbindung; die Möglichkeit, Geräte auch über Netzwerkkabel anzuschließen; und schließlich fungiert jeder Freifunk-Knoten gewissermaßen auch als "Repeater", d.h. dieser Knoten vergrößert die Reichweite des Freifunk-Netzwerks.

Bekommst du zuhause noch kein Freifunk, hast aber bereits einen Internet-Zugang per DSL o.ä., so bekommst du mit einem eigenen Freifunk-Router ein hervorragendes WLAN für Gäste und Nachbarn.

Ich würde mich gern per Richtfunk mit einem Standort des Berlin Backbone verbinden, wie funktioniert das?

Dazu brauchst Du eine Sichtkontakt zum dem Standort des BBB, eine Richtantenne, einen Freifunk-Router und dieses Tutorial: Berlin:Tutorial:Mit einer Richtantenne und einem Freifunk-Router in den Berliner Freifunk

Wie ist die rechtliche Lage in Bezug auf Teilen des Internet-Anschlusses?

Ein Betreiber von offenem WLAN kann seit 2017 weder kostenpflichtig abgemahnt noch schadenersatzpflichtig gemacht werden, siehe §8 (3) Telemediengesetz bzw. https://freifunkstattangst.de/ .

  • Wer sich für den Betrieb ohne Tunnel entscheidet und doch noch Abmahnungen bekommt, kann entweder den Abmahnbeantworter benutzen oder sich an den Förderverein wenden.
  • Der Betrieb mit Tunnel ist ebenfalls möglich (siehe Abschnitt Image-Typen). Der Freifunk-Datenverkehr ist dann mit den Tunnel-Server assoziiert, nicht mit dem Internet-Anschluss des Betreibers des Freifunk-Knotens.

Ich sehe ein Freifunk-WLAN. Wie finde ich heraus, wo der zugehörige Router steht?

Eventuell ist der Knoten auf openwifimap.net bzw. Hopglass eingetragen. Dort finden sich evtl. auch Kontaktinformationen des Betreibers des Knotens.

Falls du dich in das WLAN einloggen kannst, kannst du auch die Webseite des Routers aufrufen, auf der sich evtl. Informationen finden. Dazu musst du, nachdem du dich eingeloggt hast, im Browser auf http://frei.funk/ gehen. Sollte das nicht funktionieren, musst du die IP deines aktuellen Netzwerk-Gateways herausfinden und sie im Browser aufrufen (wie z.B. http://10.230.6.7/).

Zuguterletzt kannst du auch einfach auf der Mailingliste nachfragen.

Was hat es mit den SSIDs "intern-chXX.berlin.freifunk.net" auf sich?

Das sind die internen WLAN-Netze, über die die Knoten untereinander im Mesh Daten austauschen. Endgeräte ohne entsprechende Software (in Berlin meist OLSRv1) können und sollten sich mit diesen WLANs nicht verbinden.

Was leistet ein normaler Knoten mit der Berliner Freifunk-Firmware?

Er kann Verbindung zum Freifunk-Mesh herstellen; für normale Clients wie Smartphones und Notebooks erscheint der Knoten wie ein normaler Access Point.

Sollte bereits eine Internet-Verbindung via DSL o.ä. zur Verfügung stehen, kann der Knoten dieses im Mesh freigeben, wobei die freigegebene Bandbreite begrenzt werden kann.

An den LAN-Ports des Routers liegt normalerweise Freifunk-Netz an.

Der Freifunk-Router ist in der normalen Konfiguration "hinter" den normalen DSL-/Kabel-Router anzuschließen; ein Zugriff aus dem Freifunk-Netz auf das Heimnetz ist nicht möglich.

Mit etwas manueller Konfiguration lässt sich ein Freifunk-Knoten gleichzeitig als normaler Haus-Router benutzen, sofern ein dediziertes DSL-/Kabelmodem vorhanden ist. Eine Anleitung dazu gibt es hier.

Die FAQ Technik geht auch noch allgemeiner auf diese Frage ein.

Mein Router erscheint auf der Freifunk-Übersichtskarte nicht bzw. ich möchte ihn wieder löschen, wie geht das?

Der Knoten erscheint auf openwifimap.net bzw. Hopglass, sofern bei der Ersteinrichtung Koordinaten eingetragen wurden und der Router ca. eine Stunde mit Internet-Verbindung lief.

Knoten, die mehr als eine Woche ohne Internet-Verbindung blieben, werden aus der Karte wieder gelöscht; aus dem Monitor verschwinden sie nach rund einem Monat.

Wie läuft das Firmware-Update eines bereits mit der Berliner Freifunk-Firmware ausgestatteten Routers?

Einfach das passende Firmware-Image herunterladen (die "sysupgrade"-Variante), in das Router-Webfrontend als Admin einloggen und das Image per "System / Backup/Flash Firmware", "Flash new firmware image" einspielen. Wenn das entsprechende Häkchen gesetzt ist, bleiben die alten Einstellungen erhalten.

Für Kommandozeilen/SSH-Leute: Image z.B. per wget nach /tmp herunterladen und per sysupgrade flashen. Per Default bleiben /etc/config/* und einige weitere ausgewählte Dateien (Details) erhalten; alle selbst nachinstallieren Packages oder Dateien an anderen Stellen im Dateisystem gehen verloren.

Netzwerk

Nehmen mir die Freifunker nicht meine Bandbreite weg, wenn ich mein Internet freigebe?

In der Berliner Firmware wird konfiguriert, wieviel Bandbreite für Freifunk freigegeben werden soll. Alternativ kannst du im Haupt-Router (der "vor" dem Freifunk-Router) den Freifunk-Router eine geringere Priorität geben; dadurch hast du immer volle Bandbreite, gleichzeitig können die Freifunker aber auch die volle Bandbreite nutzen, wenn du sie gerade nicht brauchst. In der Praxis stellt allerdings sowieso zur Zeit das Freifunk-VPN einen Flaschenhals dar - siehe weiter unten. Freifunk kann entsprechend sowieso nur die kleinsten erhältlichen DSL-Anschlüsse "saturieren".

Welche Technologie benutzt das Mesh?

Das Berliner Backbone (BBB) ist eins der ersten Freifunk-Netzwerke und benutzt größtenteils OLSRd v1. Größere Standorte benutzen häufig zusätzlich B.A.T.M.A.N., um den WLAN-Clients wenigstens innerhalb der Standort-Knoten Roaming zu ermöglichen. Die Parameter für das Adhoc-Mesh sind:

  • 2.4GHz: Kanal 13, BSSID D2:CA:FF:EE:BA:BE, SSID "intern-ch13.freifunk.net"
  • 5GHz: Kanal 36, BSSID 02:36:CA:FF:EE:EE, SSID "intern-ch36.freifunk.net"

Es gibt noch einige weitere Standorte, die mit den PBerg-Parametern laufen (Kanal 10, BSSID 02:CA:FF:EE:BA:BE). Einige Standorte experimentieren Stand Mitte 2015 mit 802.11s.

Viele Standorte nutzen das Core-Router-Setup, d.h. an einem sogenannten "Core-Router" (auf dem insbesondere OLSRd läuft) hängen per LAN angeschlossene weitere Router, die aber nur als reine Antennen/Bridges benutzt werden und auf denen typischerweise die Hersteller-Firmware läuft. Das ist unter anderem nötig, weil für die 5GHz-Richtfunkverbindungen DFS vorgeschrieben ist, das aber von OpenWrt/der Freifunk-Firmware nicht unterstützt wird. DFS ist auch der Grund, weswegen die Richtfunkverbindungen zwischen Standorten häufig nicht im Adhoc-Modus, sondern via AP<->Client laufen; Adhoc unterstützt kein DFS. Solltest du dich mit einem Standort verbinden wollen, der als Client-Seite einer solchen Verbindung läuft, musst du dich mit dem Standortbetreiber in Verbindung setzen und eine Lösung suchen.

Wieso müssen IPs und VPN-Zugang gesondert beantragt werden? In anderen Communities ist das einfacher!

Seit Firmware 1.0.2 wird der Tunnel automatisch eingerichtet; eine Registrierung dafür ist nicht mehr nötig.

Um etwas weiter auszuholen: Viele andere Communities benutzen Gluon bzw. damit B.A.T.M.A.N. und fastd. Mit dieser Technik wird ein einzelnes verbundenes OSI Layer 2-Netz (MAC-Ebene) aufgespannt. Das hat Vorteile, aber auch Nachteile - teilweise technischer, teilweise politischer Natur.

  • Einige Dienste (VPN, DHCP) müssen von einer zentralen Stelle angeboten werden
  • BATMAN skaliert nicht zu sehr großen Netzen (ohne weiteres) - siehe auch dieses Posting

In Berlin war/ist es den Freifunkern wichtig, keine zentralisierte Infrastruktur aufzubauen:

  • Der Tunnel ist frei wählbar (ggf. mit manueller Konfiguration)
  • IPs sind prinzipiell frei wählbar (die Registrierung dient nur dazu, doppelt belegte IPs zu vermeiden)
  • Lokale abweichende Installationen sind möglich (siehe z.B. "Kiez-Setup" im Artikel BATMAN-Konfiguration)

Wenn du eine einfachere Lösung z.B. für dein Kiez anbieten möchtest, vielleicht auch auf Gluon-Basis, nimm' Kontakt mit den anderen Berliner Freifunkern auf.

Außerdem ist ein vereinfachter Einrichtungsassistent in Arbeit, der IP/VPN-Konfiguration auch mit wenigen Clicks ermöglichen soll.

Ist das Netz abhörsicher?

  • Die Verbindung von Clients zu Freifunk-Knoten ist unverschlüsselt (offener AP).
  • Die Verbindung der Freifunk-Knoten untereinander erfolgt unverschlüsselt.
  • Die Verbindung von Freifunk-Knoten, die per DSL/Kabel angeschlossen sind, ist - ggf. trotz des Stichworts "VPN" - unverschlüsselt, da die Router zuwenig Rechenleistung für hohen Durchsatz haben, das Rechenleistung auf Seiten des Servers einspart und bereits die Teilstrecken vorher unverschlüsselt waren.

Da fast alle Webseiten heutzutage HTTPS benutzen (es empfiehlt sich die Benutzung von HTTPS Everywhere), lassen sich trotzdem keine Inhaltsdaten ("Was wurde von meinem Browser angezeigt; was habe ich in Web-Formularen eingegeben") von Dritten mitlesen. Verbindungsdaten ("Mit welchem Server bin ich gerade in Kontakt") sind jedoch auch mit HTTPS nicht gesichert. Wer z.B. über Freifunk Verbindung zu einem Firmen-VPN oder anderem verschlüsselten VPN aufbaut, ist komplett abhörsicher.

Grundlegende Hinweise zum sicheren Umgang mit dem Rechner in offenen Netzen bzw. im Internet sind im Artikel Sicherheit nachzulesen.

Ist mein privates Netz sicher vom Freifunk-Netz abgetrennt?

Durch Nutzung von Policy Routing stellt die Berliner Firmware sicher, dass der Traffic, der von Clients im Freifunknetz kommt, nicht an das über den WAN-Port angeschlossene Netzwerk geroutet wird. Dadurch ist für Freifunk-Clients nur Zugriff auf andere Mesh-Router oder auf das Internet (ggf. via Tunnel) möglich.

Direkt auf dem Freifunk-Router installierte eigene Dienste und auch ggf. der per Konsole eingeloggte Administrator nutzen direkt das Netzwerk am WAN-Port.

Ein einfacher Test, ob die Trennung von Freifunk und privatem LAN auch korrekt funktioniert, ist im Artikel Sicherheit beschrieben. Insbesondere bei größeren manuellen Konfigurationsänderungen ist dieser Test empfehlenswert.

Allgemeine Hardwarefragen

Kann ich den Router XYZ/den alten Linksys WRT54G mit der aktuellen Firmware benutzen?

Es werden die Router unterstützt, die auf der Firmwareseite in der Tabelle aufgeführt sind.
Empfehlenswert wiederum sind davon nur Geräte mit >=8MB Flash und >=64MB RAM. Der alte WRT54G bietet mit nur 16MB RAM deutlich zu wenig Ressourcen, außerdem unterstützt seine WLAN-Hardware VAPs nicht, könnte also nur Meshen (und das auch nur mit 802.11g und nicht 802.11n) und nicht parallel einen Access Point anbieten.

Eine Übersicht der Hardware gibt es unter:

Welche günstigen Router kann ich benutzen?

Die Berliner Firmware unterstützt u.a. den GL-AR150 (ca. 28€, 16MB Flash). Der bietet 64MB RAM, 1x USB, unterstütz (nur) 2.4GHz und wird per Micro-USB (5V, 2A) mit Strom versorgt. Der AR-150 bietet optional sogar PoE und eine externe Antenne.

Falls man einen gebrauchten Router anschaffen kann, ist der TL-WR1043N v5 sehr empfehlenswert. Den kan man momentan (Juli 2019) ganz gut auf einschlägigen Portalen für rund 20-30€ bekommen. Dafür gibt es 2.4GHz, Gigabit-LAN, 64MB RAM und 16MB Flash. Außerdem ist er mit 3x3 MIMO auch schwierigen Funksituationen (dicke Wände/ viele Störquellen, etc.) gewachsen.

Für Berlin nicht empfehlenswert sind die alten Versionen (bis inkl. v12) des TL-WR841.

Services im Freifunk-Netz

Ich möchte mir Freifunk-interne Dienste ansehen, aber mein Freifunk-Router zeigt keine an. Warum?

Vermutlich ist dein Router nicht per WLAN-Mesh mit anderen Freifunk-Knoten verbunden. Über den Uplink läuft tatsächlich nur der Internet-Datenverkehr der Freifunk-Clients an deinem Knoten. Du musst Dir zusätzlich das BBB-VPN (manuell) einrichten.

Ein Überblick der verschiedenen im Zusammenhang mit Freifunk relevanten VPNs bzw. Tunnel-Lösungen (angepasst aus diesem Posting und aktualisiert):

Community-Tunnel, Tunneldigger (früher VPN03)
Sinn und Zweck: rechtlichen Ärger vermeiden, nichts anderes (keine Verschlüsselung o.ä.).
Wird auch von anderen Communities als Berlin benutzt.
Prinzipiell sollte es möglich sein/bleiben, auch andere VPN-Anbieter zum Angehen der Störerhaftungs-Problematik zu benutzen.
Server-Instanzen laufen nicht nur in Berlin, sondern auch teilweise bei befreundeten Hostern und anderen Communities.
BBB-VPN
Sinn und Zweck: Anbindung von nur via DSL/Kabel angebundenen "Inseln" ans BBB - nicht ins Internet. Einrichtung manuell.
Routing: OLSR
IC-VPN
Sinn und Zweck: Freifunk-Community-InterConnect. Funktioniert nur im BBB. Für Endanwender normalerweise nicht relevant.
Routing: Tinc Layer2 und BGP für Layer3

Wie kann ich einen eigenen Service erstellen?

Für die Erstellung eines Services gibt es grundsätzlich verschiedene Möglichkeiten. Hier das Beispiel für eine WebCAM mit WLAN:

  • Voraussetzung: Der DHCP vergibt Adressen ohne maskerading, also aus dem Freifunk-IP-Raum (10.230.0.0).
  • WebCam (google: netcam belkin wlan) am WLAN berlin.freifunk.net einwählen lassen.
  • Am FF-Router Web-Interface (LuCI) -> unter Administration -> Netzwerk-> "DHCP and DNS" der WebCAM die momentane IP als statische IP zuordnen.
  • Am FF-Router Web-Interface (LuCI) -> unter Administration -> Dienste-> OLSR IPv4-> Plugins-> olsrd-nameservice-xxx-> Edit

äquivalete Einträge hinzufügen:

    • services-file:
      /var/run/services_olsr
    • service:
      http://10.230.4.21:80|tcp|MrFish
      • bedeutet:
        http(s)://<URL>|tcp bzw. udp|Bezeichnung

Das sollte die einfachste Variante gewesen sein. Eine Weitere Variante wäre eine verkabelte CAM: Die Variante ist etwas schwieriger. Hier ist die IP-Adresse zu beachten. Möglicherweise gibt es keinen DHCP auf dem LAN. Möglicherweise muss man eine HNA setzen. Möglicherweise muss man eine statische Route setzen.

Hier ein alternatives externes Tutorial dazu (englisch): How to run your own Freifunk Berlin service

Spezielle Konfigurationen

Warum funktioniert mein Freifunk-Router nicht, wenn er an den Gastzugang des Haupt-Routers angeschlossen wurde?

Schließt man den Freifunk-Router an den Gastzugang z.B. einer FritzBox an, müssen ein paar Ports freigegeben werden (alle ausgehend):

  • 8942/udp (L2TP/Tunneldigger) bzw. 1194/udp (OpenVPN, nur alte Firmwares)
  • 53/udp (DNS)
  • 80/tcp und 443/tcp (HTTP bzw. HTTPS für ausgehende OpenWifiMap-Updates, Software-Updates etc.)
  • 25826/udp (collectd-Statistiken)
  • 3/icmp (ping, falls Ping-Plugin bei collectd eingeschaltet)

Allerdings gibt es Nachteile beim Betreiben des FF-Routers am Gastzugang, so ist z.B. das Web-Interface des FF-Routers so nicht aus dem LAN erreichbar, außerdem funktioniert der ggf. eingerichtete "Private AP" des Freifunk-Routers nicht richtig, da er eben nicht das LAN erweitern kann, sondern nur zum Gastzugang führt - auf jeden Fall sollte also eine Gast-SSID für den privaten AP gewählt werden.

Im Zweifelsfall kann der FF-Router einfach an einen LAN-Port gehängt werden; durch Policy Routing ist ein Zugriff auf das LAN vom FF-Netzwerk aus nicht möglich.

Welche Ports muss ich am dem Freifunk-Router vorgeschalteten Router freigeben?

Siehe vorige Frage.

Kann ich meinen Freifunk-Knoten per WLAN mit meinem privaten WLAN-Router verbinden?

Normalerweise muss ein Kabel vom privaten Router zum WAN-Port des Freifunk-Knotens gezogen werden, wenn man den eigenen Internet-Zugang freigeben will. Das WLAN des Freifunk-Knotens kann sich nicht mit dem privaten WLAN verbinden, u.a. da die WLAN-Hardware nur auf einem Kanal laufen kann und das Heimnetzwerk nicht unbedingt auf Kanal 13 läuft.

Es gibt mehrere Möglichkeiten zur Lösung des Problems.

Freifunk-Router mit einem zusätzlichen WLAN-USB-Stick ausstatten
Eine Anleitung dafür gibt es hier - das ath9k_htc-Kernel-Modul ist ab Kathleen 0.1.1 verfügbar.
Evtl. wird der reghack nötig (neuer reghack ab Kathleen 0.2.0), falls durch das neue Modul auf einmal Kanal 13 nicht mehr verfügbar ist (siehe iw list).
Vorteil dieser Lösung: Günstig. Nachteil: Konfigurationsaufwand; Konfiguration geht nach Firmware-Updates eventuell kaputt und muss wiederholt werden.
Den WAN-Port des Freifunk-Routers mit einem anderen Router, der im Client Mode läuft, verbinden
Diverse einfache Router (z.B. ein paar der TP-Links) können mit der Original-Firmware im Client Mode betrieben werden, können sich also in ein bestehendes WLAN als Client einloggen und das Netz an ihrem LAN-Port zur Verfügung stellen.
Diesen LAN-Port kann man dann mit dem WAN-Port des Freifunk-Routers verbinden.
Vorteil dieser Lösung: Robust, auch bei Firmware-Upgrades des Freifunk-Routers. Nachteil: Weiterer Router nötig; Stromverbrauch.
Zwei FF-Router benutzen, zwischen diesen meshen
Hierbei wird ein FF-Router direkt (per LAN) an den Haupt-Router angeschlossen; der andere FF-Router verbindet sich per WLAN-Meshing mit dessen FF-WLAN (nicht mit dem verschlüsselten privaten WLAN).
Vorteil dieser Lösung: Keine Spezialkonfiguration nötig, weitere Abdeckung durch FF-WLAN. Nachteil: Weiterer Router nötig; Stromverbrauch.

Ich brauche weitere IP-Adressen für mein DHCP bzw. für das weitere Interface meines neuen Dual Band-Routers, wie bekomme ich die?

Im "Expertenmodus" von config.berlin.freifunk.net lassen sich sowohl IP-Ranges als auch einzelne IPs besorgen.

  • IPv4-Präfix 32 gibt eine einzelne IP
  • IPv4-Präfix 28 gibt 14 nutzbare IPs (Standard des normalen Wizards für Wohnungs-Router)
  • IPv4-Präfix 27 gibt 30 nutzbare IPs (Standard für "Café-Router")

Brauchst du nur eine weitere IP für das weitere Interface eines Dual Band-Routers, einfach eben die eine zusätzliche IP beantragen. Willst du den DHCP-Range vergrößern, am besten alle Freifunk-IPs des Routers mit dem Link aus der alten Mail zurückgeben und neue IPs holen.

Die neuen IP-Adressen sind dann an folgenden Stellen zu ändern:

  • Netzwerk --> Schnittstellen
    • DHCP, Wireless0, ggf. Wireless1
  • Netzwerk --> Rechnernamen
    • frei.funk
  • Dienste --> OLSR IPv4
    • Registerkarte "HNA-Ankündigungen"

Ich betreibe mehrere Freifunk-Knoten dicht beieinander. Was sollte ich beachten?

Generell lässt sich sowohl hier im Wiki bei der Standort-Doku als auch in den router-configs auf GitHub spicken.

Verbindung der lokalen Knoten per LAN-Mesh

Das entlastet das WLAN.

Dazu ist etwas manuelle VLAN-Konfiguration nötig, da OLSRd 1 auf jedem Interface, auf dem gemesht werden soll, eine eigene IP braucht - einfaches Bridging der Interfaces ist nicht möglich.

Unter Luci würde ich folgendes empfehlen:

  • Unter Network/Switch ein VLAN am LAN-Switch abspalten, siehe Artikel Berlin:Switch_VLAN_Konfiguration
  • Unter Network/Interface eine IP-Adresse vergeben, entweder ein /16 oder nach Bedarf auch ein /32er Netz aus dem Berliner Freifunk-Adressbereich
  • Unter /Service/olsrv4 dieses neue Interface hinzufügen
/etc/config/network

# Das "LAN"-Interface, typischerweise DHCP-Server mit Freifunk-IPs.
config interface 'lan'
        option ifname 'eth0.1'
        ...

# Das "WAN"-Interface, typischerweise DHCP-Client an DSL-/Kabelmodem.
config interface 'wan'
        option ifname 'eth0.2'
        ...

# Das Interface zum LAN-Meshing mit anderen Knoten. Statisch auf eine Freifunk-IP konfiguriert.
config interface 'lanmesh'
        option ifname 'eth0.3'
        option ipaddr '...'
        option netmask '...'
        option proto 'static'

# VLAN-Handling für eth0 anschalten
config switch
        option enable_vlan '1'
        option name 'eth0'
        option reset '1'

# eth0.1=lan auf physikalischen Ports 3-5
config switch_vlan
        option device 'eth0'
        option ports '0t 3 4 5'
        option vlan '1'

# eth0.2=wan auf physikalischem Port 1
config switch_vlan
        option device 'eth0'
        option ports '0t 1'
        option vlan '2'

# eth0.3=lanmesh auf physikalischem Port 2
config switch_vlan
        option device 'eth0'
        option ports '0t 2'
        option vlan '3'

/etc/config/olsrd

config Interface
        option Mode 'ether'
        option ignore '0'
        option interface 'lanmesh'

Roaming auf den DHCP-Interfaces unterstützen

Auf den DHCP-Interfaces der Knoten sollte möglichst B.A.T.M.A.N. eingerichtet sein, damit Roaming der Clients zwischen den Knoten funktioniert. Sollte das zu aufwendig sein, am besten die SSID der Freifunk-APs abweichend vom Default berlin.freifunk.net setzen, z.B. berlin.freifunk.net/#KnotenName, damit die Clients nicht roamen.

Wie kann ich WLAN-Clients nach dem Login eine das Projekt erklärende Seite ("Splash-Screen") zeigen?

Im Berliner Freifunknetz sind Splash-Screens weder üblich, noch gerne gesehen. Dem Nutzen als Werbefläche für Freifunk, stehen viele Nachteile entgegen. Allen voran:

  1. sie sind nicht barrierefrei
  2. sie sind nervig.
  3. sie sind nervig!!

Weitere Gründe, warum du keine Splash-Screens einrichten solltest, hat Freifunk Aachen hier zusammengefasst.


Du willst immernoch einen Splash-Screen installieren?! Okay, aber wundere dich nicht, falls du von anderen Freifunkern Kritik und Unverständnis erntest. ;)

Ab falter-1.1.0 kannst du das dafür zuständige Paket luci-app-splash über einen einfachen Befehl installieren: opkg install luci-app-splash. In den Versionen vor falter ist das Paket nicht in der Firmware oder den vorkonfigurierten opkg-Quellen enthalten. Ein experimenteller und sehr unschöner Workaround ist, der Datei /etc/opkg/customfeeds.conf folgendes hinzuzufügen:

src/gz barrier_breaker_base http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/base
src/gz barrier_breaker_oldpackages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/oldpackages
src/gz barrier_breaker_packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/packages
src/gz barrier_breaker_luci http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/mikrotik/packages/luci/

Stimme die Version der Package-Feeds an besten auf die OpenWrt-Version deiner Firmware ab. Bevor du das tust, überlge bitte, ob ein Update auf eine neue Firmware-Version vielleicht einfacher ist. :)

Wie priorisiere ich bestimmte Verbindungen im Netzwerk?

Mit der LinkQualityMult-Option des OLSRd lassen sich bestimme Verbindungen künstlich verbessern bzw. verschlechtern. Ein Auszug aus der OLSR-Konfiguration olsrd.conf findet man auf GitHub.

Wie kann ich einen meinen Freifunk-Router zusätzlich als Repeater für mein privates W-LAN nutzen?

Seit der Einführung der neuen Firmware Hedy 1.0.0 im März 2018 ist die entsprechende Funktion, wegen geringer Nachfrage, im Assistenten nicht mehr enthalten. Falls dennoch benötigt, gibt es unter Berlin:erweiterte Konfiguration eine Anleitung.