Hamburg/router Schnittstellen

Aus wiki.freifunk.net
Zur Navigation springen Zur Suche springen

Router Schnittstellen

Darstellungen der Schnittstellen

In verschiedenen Formaten

VLANs

Ein Beispiel zur Konfiguration von VLANs findet sich bei den Kernroutern der Richtfunkstrecken.

Mesh on LAN/WAN

https://github.com/freifunk-gluon/gluon/wiki/Commandline-administration
Mesh on WAN geht übrigens auch über die GUI des Config-Modes.

Mesh auf einem LAN Port bei gleichzeitigem Client-Netz auf den anderen

Konfiguriert wird ein sog. Switch-Port. Dieses können LAN-, WAN-Ports oder die CPU sein. Welcher LAN-Port welchem Switch-Port entspricht entnimmt man der OpenWRT Seite für das jeweilige Router-Modell. Hier als Beispiel die Tabelle für den TP-Link TL-WDR3600.

In folgendem Beispiel wird nur LAN-Port 1 = Switch-Port 2 für mesh konfiguriert. Die anderen LAN-Ports bleiben Client-Netz.

vi /etc/config/network

Es wird Switch Port 2 aus dem default VLAN 1 entfernt:

config switch_vlan
	option device 'eth0' 
	option vlan '1'
	option ports '0t 3 4 5'

Das VLAN3 wird hinzugefügt und bildet eine Brücke zwischen der CPU (Switch-Port 0) und unserem LAN-Port 1 (Switch-Port 2):

config switch_vlan
	option device 'eth0'
	option vlan '3'
	option ports '0t 2'

Die client-Schnittstelle wird angepasst. Anstatt eth0 mit bat0 zu verbinden, verbindet sie nun nur noch das VLAN1 (welches Switch-Port 2 nicht mehr enthält s. oben) mit bat0:

config interface 'client'
	option ifname 'eth0.1 bat0'
	option reqprefix 'no'
	option proto 'dhcpv6'
	option type 'bridge'
	option macaddr 'BLAH-IRGENDEINE-MAC'
	option peerdns '1'

Zum Schluss wird die mesh_lan Schnittstelle hinzugefügt. Sie macht B.A.T.M.A.N.-adv auf VLAN3 (s. oben):

config interface 'mesh_lan'
	option ifname 'eth0.3'
	option mesh 'bat0'
	option proto 'batadv'