Hamburg/HOWTO Freifunk-Router und Internet-Router ohne Kabel verbinden

Aus wiki.freifunk.net
Wechseln zu: Navigation, Suche

Freifunk Hamburg



Nicht verwenden. Dieser Artikel beinhaltet Fehler!

Das ganze funktionierte aufgrund eines üblen Tippfehlers. Folgendes funktioniert nicht und ist falsch!

In diesem Beitrag wird beschrieben, wie man einen Freifunk-Router mit seinem Internet-Router über WLAN verbinden kann, falls man nicht auf eine Verbindung mit Kabel zurückgreifen kann. Der Gedanke ist, dass sich der Freifunk-Router als normaler Client (wie z.B. Smartphone, Notebook) mit dem Internet-Router verbindet und seinen gewohnten Freifunk-Dienst tut.

Durchgeführt ist dieses an einem TP-Link 842ND Version 1. Es ist möglich, dass die Einstellungen nach einem Firmware-Update erneut durchgeführt werden müssen.

WICHTIG:

Es handelt sich hierbei um eine Anpassung die von dem gedachten Einsatz des Gerätes abweicht. Somit kann es also zu unvorhersehbarem Fehlverhalten des Routers kommen.

Der Internet-Router sollte so umgestellt werden, dass dieser auf Kanal 1 funkt. Ansonsten wird es dem Freifunk-Router nicht möglich sein mit anderen Freifunk-Routern zu meshen!

Darüber hinaus ist es immer die bessere Wahl mit dem Internet-Router direkt über Kabel verbunden zu sein! (mehr Performance, höhere Sicherheit,..)

Mit dem Freifunk-Router verbinden

Zunächst müssen wir uns mit dem Freifunk-Router verbinden, um anschließend per SSH auf diesen zugreifen zu können. Dafür eignet sich zunächst eine Verbindung über Kabel, zwischen Freifunk-Router (gelbe Buchsen) und dem eigenen PC. Der Freifunk-Router wird hierfür in den Config-Mode gebracht. Um dies zu erreichen wird der sehr kleine Knopf auf der Router-Rückseite, mit der Aufschrift config/reset/wps, solange gedrückt gehalten, bis alle Router-LED einmal aufleuchten. Der Router sollte nun über die IP 192.168.1.1 erreichbar sein. Dann kann über SSH auf diesen zugegriffen werden. Für Windows-Benutzer eignet sich das Programm putty.

ssh root@192.168.1.1

Der Benutzer ist root und das Passwort ist jenes, welches nach dem aufspielen der Freifunk-Firmware gesetzt worden ist. Nun befinden wir uns auf dem Freifunk-Router und können Änderungen vornehmen.

Configs ändern

Hierfür wechsen wir zunächst einmal das Verzeichnis mit:

cd /etc/config

Dann wird die Datei network zum bearbeiten mit vim geöffnet

vim network

(Bedienungsanleitungen zu vim sind im Internet zu finden.) Und der Datei wird am Ende folgendes angehängt:

# WiFi Uplink
config interface 'uplink'
        option proto 'dhcp'

Dann die Änderungen in der Datei speichern und im selben Verzeichnis die wireless öffnen.

vim wireless

Folgendes wieder an das Dateiende anhänden:

config wifi-iface 'uplink'
       option device 'radio0'
       option network 'uplink'
       option mode 'sta'
       option ssid '<Name des WLANs mit Internet>'
       option encryption 'psk2'
       option bssid '<MAC-Adresse des Internet-Routers (steht in der Regel auf der Rückseite)>'
       option key '<WLAN-Passwort>'

Die < > sind einschließlich der < > entsprechend des WLANs auszutauschen. Nach einem reboot sollte sich der Freifunk-Router nun mit dem Internet-Router verbinden. Die Informationen hierfür stammen von: https://github.com/0x64746b/openwrt/tree/master/configs/wireless_uplink

Statische IP

Es lässt sich mit Einschränkung auch eine statische IP vergeben. Hierfür wird an die /etc/config/network folgendes angehängt:

# WiFi Uplink
config interface 'uplink'
        option proto 'static'
        option ipaddr '192.168.1.103'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

Allerdings muss dann in die /etc/resolv.conf ein nameserver eingetragen werden:

echo "nameserver 85.214.20.141" >> /etc/resolv.conf

Dieser löscht sich nach einem Neustart des Routers wieder aus der resolv.conf heraus. Wenn jemand weiß, wie sich dies ändern lässt, dann bitte ich darum diesen Beitrag zu ergänzen.

Für Verbesserungsvorschläge bin ich dankbar, Lennart



Freifunk Hamburg